Welcome to AutoForumz.com!
FAQFAQ    SearchSearch      ProfileProfile    Private MessagesPrivate Messages   Log inLog in

89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b]

 
   car problems (Home) -> 4X4 RSS
Next:  Random thoughts...  
Author Message
Ty78




Joined: Jun 14, 2005
Posts: 2



(Msg. 1) Posted: Wed Jun 15, 2005 1:31 am
Post subject: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b]

I don't know much about cars, so please be patient with me , and please help. My 89 jeep cherokee 4.0 4x4 just statrted taking about 30 seconds to start. It cranks fine, and fast, btu it takes a while to start, and when it does, it kind of sputters, and then it runs perfect. If I turn it off, and immediatly restart it it will start just fine, like it always has, but if i let it set for over 30 seconds and restart it, it is again hard to start. In the past 6 months I have replaced the plugs, wires, dist cap, rotor, starter, fuel pump, cadaledit converter (spelled wrong), and exhust. What could this possibly be? Like I said it runs fine, after it starts. I really appriciate any and all help!!! THANK YOU

 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
Carl Saiyed3

External


Since: Feb 18, 2004
Posts: 69



(Msg. 2) Posted: Fri Jun 17, 2005 1:43 am
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, PLEASE HELP!!!!! [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

Ask over in rec.autos.makers.jeep+willys about cleaning the crank position
sensor connections, throttle body, ect. Are the spark plugs OK? When was the
last time you had it tuned up?

Carl

"Ty78" wrote in message

 > I don't know much about cars, so please be patient with me , and
 > please help. My 89 jeep cherokee 4.0 4x4 just statrted taking about
 > 30 seconds to start. It cranks fine, and fast, btu it takes a while
 > to start, and when it does, it kind of sputters, and then it runs
 > perfect. If I turn it off, and immediatly restart it it will start
 > just fine, like it always has, but if i let it set for over 30 seconds
 > and restart it, it is again hard to start. In the past 6 months I
 > have replaced the plugs, wires, dist cap, rotor, starter, fuel pump,
 > cadaledit converter (spelled wrong), and exhust. What could this
 > possibly be? Like I said it runs fine, after it starts. I really
 > appriciate any and all help!!! THANK YOU
 >
 > --
 > Posted using the <a rel="nofollow" style='text-decoration: none;' href="http://www.autoforumz.com" target="_blank">http://www.autoforumz.com</a> interface, at author's request
 > Articles individually checked for conformance to usenet standards
 > Topic URL:
<a rel="nofollow" style='text-decoration: none;' href="http://www.autoforumz.com/4X4-89-Jeep-Cherokee-hard-start-HELP-ftopict124604.html" target="_blank">http://www.autoforumz.com/4X4-89-Jeep-Cherokee-hard-start-HELP-ftopict...604.htm</a>
 > Visit Topic URL to contact author (reg. req'd). Report abuse:
<a rel="nofollow" style='text-decoration: none;' href="http://www.autoforumz.com/eform.php?p=606678" target="_blank">http://www.autoforumz.com/eform.php?p=606678</a>

 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
Ty78




Joined: Jun 14, 2005
Posts: 2



(Msg. 3) Posted: Fri Jun 17, 2005 11:28 pm
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, PLEASE HELP!!!!! [Login to view extended thread Info.]

Hi, thanks for the response! The plugs, wires, cap, and rotor are all less than 3 months old, it also has a brand new starter, water pump, cateletic converter, fuel filter, air filter, within the last 4 months.... I just passed emmisions testing today with flying colors (exept I had to buy a new gas cap), so doesnt that rule out a few possible sensors?? Thanks again... And please explain where you told me to ask??
Thanks
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
SnoMan




Joined: May 17, 2005
Posts: 1396



(Msg. 4) Posted: Sat Jun 18, 2005 12:11 am
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![ [Login to view extended thread Info.]

Ty78 wrote:
I don't know much about cars, so please be patient with me , and please help. My 89 jeep cherokee 4.0 4x4 just statrted taking about 30 seconds to start. It cranks fine, and fast, btu it takes a while to start, and when it does, it kind of sputters, and then it runs perfect. If I turn it off, and immediatly restart it it will start just fine, like it always has, but if i let it set for over 30 seconds and restart it, it is again hard to start. In the past 6 months I have replaced the plugs, wires, dist cap, rotor, starter, fuel pump, cadaledit converter (spelled wrong), and exhust. What could this possibly be? Like I said it runs fine, after it starts. I really appriciate any and all help!!! THANK YOU


You might check the fuel line from tank for a pin hole that lets pump lose prime and lets air suck in with fuel and takes a while to prime up explaining the rough running when it first starts and fine performance otherwise. If there is a leak it will be closer to engine than tank I think but check all of it.
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
Carl Saiyed3

External


Since: Feb 18, 2004
Posts: 69



(Msg. 5) Posted: Sun Jun 19, 2005 10:45 pm
Post subject: Re: Re: 89 Jeep Cherokee 4.0 hard to start, PLEASE HELP!!!!! [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

another usenet group called rec.autots.makes.jeep+willys.

Carl

"Ty78" wrote in message

 > "Carl Saiyed3" wrote:
  > > Ask over in rec.autos.makers.jeep+willys about cleaning the
  > > crank position
  > > sensor connections, throttle body, ect. Are the spark plugs
  > > OK? When was the
  > > last time you had it tuned up?
  > >
  > > Carl
  > >


   > > > I don't know much about cars, so please be patient with me ,
  > > and
   > > > please help. My 89 jeep cherokee 4.0 4x4 just statrted
  > > taking about
   > > > 30 seconds to start. It cranks fine, and fast, btu it takes
  > > a while
   > > > to start, and when it does, it kind of sputters, and then it
  > > runs
   > > > perfect. If I turn it off, and immediatly restart it it
  > > will start
   > > > just fine, like it always has, but if i let it set for over
  > > 30 seconds
   > > > and restart it, it is again hard to start. In the past 6
  > > months I
   > > > have replaced the plugs, wires, dist cap, rotor, starter,
  > > fuel pump,
   > > > cadaledit converter (spelled wrong), and exhust. What
  > > could this
   > > > possibly be? Like I said it runs fine, after it starts. I
  > > really
   > > > appriciate any and all help!!! THANK YOU
   > > >
   > > > --
   > > > Posted using the <a rel="nofollow" style='text-decoration: none;' href="http://www.autoforumz.com" target="_blank">http://www.autoforumz.com</a> interface, at author's
request
   > > > Articles individually checked for conformance to usenet
  > > standards
   > > > Topic URL:
  > >
<a rel="nofollow" style='text-decoration: none;' href="http://www.autoforumz.com/4X4-89-Jeep-Cherokee-hard-start-HELP-ftopict124604.html" target="_blank">http://www.autoforumz.com/4X4-89-Jeep-Cherokee-hard-start-HELP-ftopict...604.htm</a>
   > > > Visit Topic URL to contact author (reg. req'd). Report
  > > abuse:
<font color=green>  > > <a rel="nofollow" style='text-decoration: none;' href="http://www.autoforumz.com/eform.php?p=606678</font" target="_blank">http://www.autoforumz.com/eform.php?p=606678</font</a>>
 >
 > Hi, thanks for the response! The plugs, wires, cap, and rotor are
 > all less than 3 months old, it also has a brand new starter, water
 > pump, cateletic converter, fuel filter, air filter, within the last 4
 > months.... I just passed emmisions testing today with flying colors
 > (exept I had to buy a new gas cap), so doesnt that rule out a few
 > possible sensors?? Thanks again... And please explain where you
 > told me to ask??
 > Thanks
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
langer1




Joined: Jun 07, 2005
Posts: 8



(Msg. 6) Posted: Mon Jun 20, 2005 12:10 am
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![ [Login to view extended thread Info.]

Ty78 wrote:
I don't know much about cars, so please be patient with me , and please help. My 89 jeep cherokee 4.0 4x4 just statrted taking about 30 seconds to start. It cranks fine, and fast, btu it takes a while to start, and when it does, it kind of sputters, and then it runs perfect. If I turn it off, and immediatly restart it it will start just fine, like it always has, but if i let it set for over 30 seconds and restart it, it is again hard to start. In the past 6 months I have replaced the plugs, wires, dist cap, rotor, starter, fuel pump, cadaledit converter (spelled wrong), and exhust. What could this possibly be? Like I said it runs fine, after it starts. I really appriciate any and all help!!! THANK YOU


Sounds like time to put a new fuel filter in her.
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
bigtee62

External


Since: Apr 24, 2005
Posts: 5



(Msg. 7) Posted: Sun Jun 26, 2005 3:32 am
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, PLEASE HELP!!!!! [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

I had the same problem with 2 of my jeeps both 4.0 both 1989 I replaces
crankcase postion sensor in both no problems after theat
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
timcole




Joined: Jun 30, 2005
Posts: 2



(Msg. 8) Posted: Thu Jun 30, 2005 7:13 am
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, PLEASE HELP!!!!! [Login to view extended thread Info.]

Back to top
Login to vote
timcole




Joined: Jun 30, 2005
Posts: 2



(Msg. 9) Posted: Thu Jun 30, 2005 7:31 am
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![ [Login to view extended thread Info.]

Hey - me too! Not only that, but the engine misses erratically, maybe two cylinders! Started a few months ago -- 118,000+ miles -- before that, it ran fine.
I have replaced plugs, leads, distributor cap and rotor, fuel filter, and fuel injector o-rings; I've blown out or cleaned the CCV line, the Throttle Barrel, the TPS (and readjusted it according to specs), and the IAS.
What I do have wrong: I can't get the o-rings to seal on Fuel Injector #3; I might have a fuel pressure problem (don't have a gauge).
Not only does it miss and squirt gas out of the Injector seal, but it dies when I take my foot off the accelerator (it won't idle any more without stalling); it stinks something fierce on the road and attracts a lot of attention; hesitates on acceleration from a stop, but occasionally runs fairly decent, especially from cold.
A few months ago, this thing beat a lot of people from the light (maybe I did that too often . . .). I'm retired and lost half my pension and all my benefits and life insurance -- still have a mortgage. I have a summer job inspecting corn fields and need my Jeep for that (gets hilly, and slippery under the irrigators).
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
whonea

External


Since: Nov 02, 2004
Posts: 40



(Msg. 10) Posted: Sat Jul 02, 2005 5:55 am
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![ [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

On Sat, 2 Jul 2005 03:35:52 UTC timcole
wrote:

> "Ty78" wrote:
> > I don't know much about cars, so please be patient with me ,
> > and please help. My 89 jeep cherokee 4.0 4x4 just statrted
> > taking about 30 seconds to start. It cranks fine, and fast,
> > btu it takes a while to start, and when it does, it kind of
> > sputters, and then it runs perfect. If I turn it off, and
> > immediatly restart it it will start just fine, like it always
> > has, but if i let it set for over 30 seconds and restart it,
> > it is again hard to start. In the past 6 months I have
> > replaced the plugs, wires, dist cap, rotor, starter, fuel
> > pump, cadaledit converter (spelled wrong), and exhust. What
> > could this possibly be? Like I said it runs fine, after it
> > starts. I really appriciate any and all help!!! THANK
> > YOU[b:f0c179ca4f][/b:f0c179ca4f]
>
> Hey - me too! Not only that, but the engine misses erratically, maybe
> two cylinders! Started a few months ago -- 118,000+ miles -- before
> that, it ran fine.
> I have replaced plugs, leads, distributor cap and rotor, fuel filter,
> and fuel injector o-rings; I∆ve blown out or cleaned the CCV line,
> the Throttle Barrel, the TPS (and readjusted it according to specs),
> and the IAS.
> What I do have wrong: I can∆t get the o-rings to seal on Fuel
> Injector #3; I might have a fuel pressure problem (don∆t have a
> gauge).
> Not only does it miss and squirt gas out of the Injector seal, but it
> dies when I take my foot off the accelerator (it won∆t idle any more
> without stalling); it stinks something fierce on the road and attracts
> a lot of attention; hesitates on acceleration from a stop, but
> occasionally runs fairly decent, especially from cold.
> A few months ago, this thing beat a lot of people from the light
> (maybe I did that too often . . .). I∆m retired and lost half my
> pension and all my benefits and life insurance -- still have a
> mortgage. I have a summer job inspecting corn fields and need my Jeep
> for that (gets hilly, and slippery under the irrigators).

Tim, the problem is that the leaking injector seal lets the pressure
drop - you would see this immediately with a fuel pressure guage. Fix
the injector seal! Open the hood and look where the fuel from that
injector is going: straight down onto the exhaust. Are you sure the
leak is from the o-ring on the rail? Both of the ones I've replaced
were actually leaking around the electrical plug. For the first, the
cure is new o-rings (careful, some kits have two sizes and
compositions so put the right ones on the right end). FIX THE LEAK!
It's a fiew waiting to happen.

Ty, yours sounds like a fuel pressure problem as well but since you
don't see a leak it's more likely to be bleeding off pressure back to
the tank. You have a pressure regulator on the forward end of the
fuel rail that will do this if the regualtor is shot and leaking
through. Try this: turn the key on and listen for the fuel pump to
run (don't go all the way to the starter position). When it stops
running, turn the key off then turn it back on to cycle the fuel pump
again. Do this several times then try to start the engine. If it
catches fairly quickly, then it's likely a pressure problem. To be
sure, do the key cycle thing a couple of times then turn it off and
press the center pin in the schroeder valve (oversized tire valve)
near the front of the fuel rail. Hold a rag to catch any gas. You
should get a decent spray even after waiting 5-10 minutes - mine holds
a noticable pressure overnight. If it just dribbles out, then you
know it's fuel pressure. Since you've changed the pump, it's most
likely the regulator but there is a test for that so write back when
you try the above steps. It could also be losing pressure through an
injector leaking into the manifold so a couple more tests migh be
needed. BTW, the 87-89 4.0 used a Renix fuel control computer and it
takes relatively long to fire up cold under any circumstances (about
one full turn of the engine). 30 seconds is way too long, but 5-6
seconds is not that unusual. The later MOPAR models catch right away.

For both of you, a fuel pressure guage is $12 - $18 bucks at the local
Advanced Auto or Auto Zone. Worth the price is savings on unnecessary
parts and agravation

--
Will Honea
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
extremetjs

External


Since: Jun 24, 2005
Posts: 3



(Msg. 11) Posted: Sat Jul 02, 2005 6:55 pm
Post subject: Re: Re: 89 Jeep Cherokee 4.0 hard to start, PLEASE HELP!!!!! [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

"timcole" wrote in message

> "" wrote:
> > I had the same problem with 2 of my jeeps both 4.0 both 1989 I
> > replaces
> > crankcase postion sensor in both no problems after theat
>
> Is this the same as the Throttle Position Sensor?
>
> --

no they are 2 diffrent sensors

LRO



> Posted using the http://www.autoforumz.com interface, at author's request
> Articles individually checked for conformance to usenet standards
> Topic URL:
> http://www.autoforumz.com/4X4-89-Jeep-Cherokee-hard-start-HELP-ftopict...604.htm
> Visit Topic URL to contact author (reg. req'd). Report abuse:
> http://www.autoforumz.com/eform.php?p=618280
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
Mike Romain

External


Since: Dec 17, 2003
Posts: 419



(Msg. 12) Posted: Sat Jul 02, 2005 8:14 pm
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![ [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

timcole wrote:
>
> "Ty78" wrote:
> > I don't know much about cars, so please be patient with me ,
> > and please help. My 89 jeep cherokee 4.0 4x4 just statrted
> > taking about 30 seconds to start. It cranks fine, and fast,
> > btu it takes a while to start, and when it does, it kind of
> > sputters, and then it runs perfect. If I turn it off, and
> > immediatly restart it it will start just fine, like it always
> > has, but if i let it set for over 30 seconds and restart it,
> > it is again hard to start. In the past 6 months I have
> > replaced the plugs, wires, dist cap, rotor, starter, fuel
> > pump, cadaledit converter (spelled wrong), and exhust. What
> > could this possibly be? Like I said it runs fine, after it
> > starts. I really appriciate any and all help!!! THANK
> > YOU[b:f0c179ca4f][/b:f0c179ca4f]
>
> Hey - me too! Not only that, but the engine misses erratically, maybe
> two cylinders! Started a few months ago -- 118,000+ miles -- before
> that, it ran fine.
> I have replaced plugs, leads, distributor cap and rotor, fuel filter,
> and fuel injector o-rings; Iíve blown out or cleaned the CCV line,
> the Throttle Barrel, the TPS (and readjusted it according to specs),
> and the IAS.
> What I do have wrong: I canít get the o-rings to seal on Fuel
> Injector #3; I might have a fuel pressure problem (donít have a
> gauge).
> Not only does it miss and squirt gas out of the Injector seal, but it
> dies when I take my foot off the accelerator (it wonít idle any more
> without stalling); it stinks something fierce on the road and attracts
> a lot of attention; hesitates on acceleration from a stop, but
> occasionally runs fairly decent, especially from cold.
> A few months ago, this thing beat a lot of people from the light
> (maybe I did that too often . . .). Iím retired and lost half my
> pension and all my benefits and life insurance -- still have a
> mortgage. I have a summer job inspecting corn fields and need my Jeep
> for that (gets hilly, and slippery under the irrigators).

There is a recall on the O2 sensor for those renix systems. If you
haven't had it done, I recommend it.

If they will touch an engine that is about to explode that is...... You
gotta stop the gas leak, it is not safe to drive anywhere like that.

They have a fuel filter back near the tank on the frame rail and if it
gets plugged, it will be hard to start and miss.

Mike
86/00 CJ7 Laredo, 33x9.5 BFG Muds, 'glass nose to tail in '00
88 Cherokee 235 BFG AT's
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
ajeeperman

External


Since: Nov 01, 2004
Posts: 22



(Msg. 13) Posted: Fri Jul 08, 2005 10:32 pm
Post subject: Re: 89 Jeep Cherokee 4.0 hard to start, PLEASE HELP!!!!! [Login to view extended thread Info.]
Archived from groups: per prev. post (more info?)

sounds like the fuel pump is taking a while to buildup enough pressure to
start. then ok unless you let it set awhile and pressure has to build up
again
old john


"Ty78" wrote in message

> I don't know much about cars, so please be patient with me , and
> please help. My 89 jeep cherokee 4.0 4x4 just statrted taking about
> 30 seconds to start. It cranks fine, and fast, btu it takes a while
> to start, and when it does, it kind of sputters, and then it runs
> perfect. If I turn it off, and immediatly restart it it will start
> just fine, like it always has, but if i let it set for over 30 seconds
> and restart it, it is again hard to start. In the past 6 months I
> have replaced the plugs, wires, dist cap, rotor, starter, fuel pump,
> cadaledit converter (spelled wrong), and exhust. What could this
> possibly be? Like I said it runs fine, after it starts. I really
> appriciate any and all help!!! THANK YOU
>
> --
> Posted using the http://www.autoforumz.com interface, at author's request
> Articles individually checked for conformance to usenet standards
> Topic URL:
http://www.autoforumz.com/4X4-89-Jeep-Cherokee-hard-start-HELP-ftopict124604
..html
> Visit Topic URL to contact author (reg. req'd). Report abuse:
http://www.autoforumz.com/eform.php?p=606678
 >> Stay informed about: 89 Jeep Cherokee 4.0 hard to start, [b]PLEASE HELP!!!!![/b] 
Back to top
Login to vote
Display posts from previous:   
Related Topics:
sluggish start on my 91 Jeep Cherokee Laredo - Hi all! Jeep girl here needing some help - my 91 Jeep Cherokee Laredo has suddenly decided to start sluggish (best word to describe it, I guess). When I turn the key, the turning-over-sound is very sluggish sounding/feeling, and then it catches and run...

89 Jeep Cherokee Won't Start - No Fuel Injector Pulse - Hey, actually Help! Here's my symptoms: 1. Cranks fine 2. Lots of good spark 3. Timing was set TDC on compression stroke.. verified twice. 4. Fuel Rail is pressurized 5. Crank Pos Sensor functional (as far as we can tell) 6. Map Sensor Functional..

Jeep Cherokee 4x4 v6 - Happy holidays all, I need the skinny on this Jeep. Looking to purchase a used one from 1999 to 2002 with about 45 to 80k on it. Any advice will be greatly appreciated. Thanks! E.

Jeep Cherokee - [b:ad2ac81402][color=darkblue:ad2ac81402][/color:ad2ac81402] 1995 Jeep 4.0L Runs fine except every once in a while it shuts down at highway speeds. Lost power for split second and then pops right back on. Stalled once on highway approx.70mph and was able...

1990 Jeep Cherokee - I just purchased a 1990 Jeep Cherokee. If I let the car idle, the check antilock light comes on. When I turn off the engine and restart the light is off. If I'm driving on the freeway no light. Any suggestions?
   car problems (Home) -> 4X4 All times are: Pacific Time (US & Canada)
Page 1 of 1

 
You can post new topics in this forum
You can reply to topics in this forum
You can edit your posts in this forum
You can delete your posts in this forum
You can vote in polls in this forum



[ Contact us | Terms of Service/Privacy Policy ]